Newtonsoft 3.5 is .net 4.0

Jan 22, 2014 at 7:48 AM
My project target framework is .Net 3.5. So I downloaded the json.newtonsoft package, and used the 3.5.dll. But every time I compiled it, a 4.0 dll came out. So I looked with dotpeek in the .Net 3.5 json dll and saw that it is 4.0. So I removed it from my project and added the 2.0 dll, but then appeared this error: Error 13 Missing compiler required member 'System.Runtime.CompilerServices.ExtensionAttribute..ctor'.
My question is now, how can I use this libary in my 3.5 .Net Project, that the ouput dll is really 3.5 .Net dll?
Marked as answer by AstralisSomnium on 2/4/2014 at 5:45 AM